Cross Browser

Todo diseñador o desarrollador web se ha enfrentado en alguna ocasión al interrogante de "¿A qué navegadores tengo que dar soporte?" e incluso a la eterna disputa con el cliente final al que parece le cuesta entender que su navegador está anticuado y no soporta las tecnologías web con las que se van a desarrollar su nuevo sitio; quieren lo último y que funcione en todos los navegadores pero sin pagar el tiempo extra que conlleva esta adaptación del código.

Como digo, son todos los desarrolladores los que se encuentran (además con frecuencia) con este problema y están cansados una y otra vez de cuestionarse esto; incluso alguno se siente mal si no consigue que la web desarrollada sea compatible con Internet Explorer 6.

¿Pero qué es lo más recomendable? ¿Qué es lo correcto? Pues bien, esto es muy subjetivo. Yo, por ejemplo, hace tiempo que no doy soporte más allá de Internet Explorer 8, Safari 4, Chrome 15 y Firefox 9. Por normal general intento dar soporte a dos versiones anteriores a la actual. Como digo, esto es subjetivo y depende en gran medida de lo pactado con el cliente, pero tras una buena explicación de por qué no trae cuenta dar soporte a estos navegadores (generalmente la propia gráfica de Google Analytics se lo explica) ceden.

Por eso, personalmente, no me gusta dar soporte a versiones anteriores a las arriba mencionadas bajo ningún concepto; aunque siempre he pensado que lo lógico sería dar soporte a la última versión de cada navegador (aunque hay que pensar en los perezosos que no se actualizan).

¿Y tú, qué versiones soportas?